Cannot access OSM

Just updated to firmware 106 and now it cannot find the HDMI signal and I cannot access the OSM. Thought I would go into the OSM and check things, however I’ve tried pressing the joystick in any direction and cannot enter the OSM. Have restarted the unit a number of times.
Any thoughts?

Hi @hillberg,

Have you tried power cycling the monitor? Turn off and unplug the monitor for more than 15 seconds, plug it back in, and turn it on. You may need to perform this a couple of times.

As a side note, OSD is not accessible with no video input. But to wake the monitor from standby, you can access a mini menu by pressing the joystick, which allows you to switch video input and USB hub input.

I have tried power cycling it several times. Have tried HDMI, USB-C directly from the computer and DP via a Lenova port replicator. It seems the computer (Lenovo Carbon X1) identifies a second monitor but nothing on the display. I can access the OSD briefly but then it quickly goes away and I get a message something like “no video input”. Then it seems to look for video input and after a while I can get the OSD briefly again. I bought two monitors and the first one works but haven’t upgraded that one to fw106 only to fw104. Is it possible to downgrade the one I have troubles with to fw104?

It’s possible that the v106 Spectrum is currently stuck on a specific video input, but isn’t detecting anything via the input.

Connect a video source to the v106 Spectrum (e.g. via DP) then click in on the control stick so that you get some text on screen (even if it just says “no video input”). When that text is showing, tap the control stick down to switch between video inputs. Keep tapping down until you’ve switched to either auto-select or the input you’re connected to.

Once the Spectrum has an input signal it’s happy displaying, you should be able to pull up the full OSD.

1 Like