Cannot access BIOS or Windows UEFI via DP or HDMI

MODEL NUMBER: Spectrum ES07D03
Scaler Firmware Version: 107, 106
USB Firmware Version: 06A4 / 0A.89.17.02
Device Type and OS version: PC Windows 11
CPU: AMD Ryzen 9 5900X
Video connection used for Spectrum: DisplayPort or HDMI
Cable brand / specs used for connection: 8K DisplayPort 1.4 or HDMI 2.1
Secondary video connection used for Spectrum: None
USB Hub setup: USB Type-B to USB Type-A Motherboard Back IO USB 3.2 Gen 2
Issue details: Black screen / no input detected when in Windows UEFI screen (restart via Windows “Recovery” menu to access UEFI) or BIOS/boot (no motherboard splash screen, no Windows boot animation, no BIOS settings screens work
What does the issue look like (you can provide a picture or video here, if any): Black screen, eventually powers itself off
What triggers the issue (how to replicate it): Reboot/boot
What is the percentage of this happening: 100%
If it doesn’t happen all the time, what is the alternative outcome: None
Please provide any additional details you have found: Borrowed another type of display to confirm it’s not an issue with my computer, worked as expected. But this was just to confirm the problem, I’m not going to buy another display just for getting into my system BIOS. I also updated my motherboard BIOS to confirm that wasn’t part of the problem.


I’ve had different levels of display during boot up depending on which firmware. Most recent one I’ve got same as you, no display until I reach Windows login. I can get into UEFI though, I just have to mash buttons blindly.

Hey @maddu

Thanking you for taking the time to provide this detailed information, I will get this to our firmware team to look into this issue and see if we can come to a resolution for this.

Try turning off VRR if HDMI or adaptive sync if DP in the OSD menu then give this a try, let me know if the issue persists then it means that particular BIOS is using a resolution not supported by the current EDID table

I can confirm that with VRR off, I can just about get a signal in time to see the BIOS button options, and all of the Windows boot process.

My board is also an ASUS ROG Strix, specifically a X570-E Gaming board.


Hello, I am having this exact same issue I’ve already submitting a ticket but haven’t heard a word in over 2 weeks. I tried the above and I have Asus ROG Strix Z690-I 12600K, 3080-12gb,

Is your input settings set to select automatically? Try setting it to the connection type you are using as this reduces the time it takes the monitor to detect a signal.

If this still does not work let me know too, we are trying to get ahold of that specific board to test on our end.

Also @erick21corona please try this too

No. Mine is always set manually.

1 Like

What GPU and type of connection are you using?
Also which version of BIOS is your ROG X570-E running?

AMD 6900xt, specifically an Asus ROG Strix LC version via HDMI 2.1

BIOS is 4403.

1 Like

Can’t access UEFI either, have to resort to a different 1080p display to make changes. No matter how many times I tried to button mash with a black screen at startup it never got me there.

While my current mobo is the ROG Crosshair VIII Impact, this was also the case on my ROG Crosshair VIII HERO Wi-Fi before switching. I’m running scaler firmware 106 on my spectrum and will probably wait till I’m done with studies to upgrade. I don’t usually have any settings applied to the monitor other than backlight strobing to reduce brightness at night.

GPU: EVGA 1080 Ti Kingpin Ed.
Connection: DP 1.4
Mobo Bios Version: 4201

Hi there,

Have you tried to set the input manually instead on automatic?

I have it set manually, I don’t ever set it to automatic :slight_smile:

1 Like


Sorry for the delay here. Confirming I set the display manually to DisplayPort and the screen just stays blank. Hopefully this gets addressed in the next firmware update.


Hi, if you are using HDMI port, you can change the HDMI port 1or 2 mode to compatibility (depend on which port you connect). This is a solution to me, but I don’t know how to fix the DP port issue.

EDIT: I found that some old graphics card vbios can also this problem, I updated my 4090 to the latest vbios and now I can enter the bios in with HDMI port @2.1 mode.

1 Like

Same here. Found this out when I went to try to play Valorant. Needed Secure Boot Enabled. Once I did this I get no post or display. I had to plug in my old 1080p monitor and worked without issue.