Blank screen and not handshaking with graphics card even at POST. Firmware updated to 104, no change in behaviour

G’day folks,

It’s my first post, and English isn’t my first language, so please excuse any errors.
So…I’m not entirely sure if this issue has been discussed previously, and in great length. I only saw posts reporting intermittent black issues during gaming or heavy-loads. I reached out to customer support and they have been quite slow to respond, only offering basic, and honestly layman fixes e.g. update the firmware, power cycle, try different cables, etc…

Like title says, I’m been having the same issue with the monitor since I received it a month ago. It refuses to display anything through DP/HDMI inputs and remain blank. Manually trying to switch to other inputs back and forth in hopes of forcing a re-sync has not been a fix. Unfortunately only a power-cycle gets the monitor to display anything again. This issue presents itself when powering up the PC at post, and when the display goes to sleep. No amount of mouse movements or keyboard clicks gets to sync up again. I recently learnt of the Windows key + Ctrl + Shift +B, to reset the graphics driver, and it is also not useful in getting the display to handshake properly.

When the monitor works, it works, with no issue whatsoever being experienced @ 4k 100/120Hz. .Interesting thing to note is the monitor OSD becoming buggy, turning yellow, not like the normal transparent default color. Text becomes garbled/corrupted and unintelligible, weird stuff indeed.

As far the firmware update, it seems like a band-aid fix. Yes the monitor displays the image faster, after a power cycle, compared to the ver. 102 firmware, but a power cycle is still always needed, most annoying. I updated the firmware to the latest version as of today ver. 104, as well as the graphics card (RTX 3080) drivers to the latest stable version 497.09.

I’m out of ideas on how to eliminate the issue completely, and if I should resign to the fact that it’s a hardware issue that can’t be fixed via firmware upgrade. I don’t feel like requesting an RMA if there’s a software fix in the pipeline for this exact issue. Also with the backed up production schedule, who knows a replacement monitor is available, or if the next monitor has a different set of issues. Monitor is flawless, no dead pixels or weird banding/DSE issues. I’d say I lucked out.

One thing to note are some forum threads discussing G-sync being the likely culprit, but a driver update, suggests that the issue has been resolved, as per some user’s feedback on the forums.

Happy to hear what you guys experienced, and any possible fixes that works.


1 Like

Hi, @daielf, and welcome to the comunity!

I’m sorry to hear that you’ve been experiencing these issues. We’ve been working with the fw dev team to get them resolved, but for the nVidia issues, they’ve been rather insistent that the fault lies with the nVidia drivers.

The latest firmware release. v105, fixes some of the latent issues with HDR and Spectrum, along with some issues for Radeon cards - but that firmware, along with a cleanly installed nVidia driver 511.23, seems to have reduced, at the very least, to completely resolved, the issues with blanking and flickering on RTX cards.

The post with the firmware is here: Spectrum | Firmware 105 Early Access

My reply with the driver info is here: Spectrum | Firmware 105 Early Access - #236

Also, thank you for being patient with the Support team. This has been an ongoing issue for a while, and we’ve not had any sort of resolution for it from the fw dev team (particularly as they ascribe these issues to nVidia drivers), and thus the Support team has had no real answers to give out. Once we are assured of the fix, they, too, will be able to give definitive answers to folks requesting support on these issues.


Thank you @nkyadav will give your proposed solutions a try. I don’t have a flickering issue to be honest and I don’t use HDR, but this possibly could be remedy. I’ll post my findings on the main early access thread, Cheers!


Hi Niraj,

I tried the firmware (105 RC)/driver update (511.23) solution and unfortunately it did nothing to solve the issue I was/still having of no-handshake after powering on the monitor, and a blank screen. I’m also still experiencing the corrupted (yellow) OSD whenever the monitor refuses to handshake with the PC/PS5. At this stage it’s probably a defective chipset or bad component. Monitor only starts displaying an image after a power-cycle, and this includes waking-up the monitor from sleep. Hope this feedback is useful somehow.

1 Like

I found that there was a legacy bios setting causing the conflict with my 3080TI where it wouldn’t show on either DP or HDMI, updating the bios to latest version and turning off the legacy item in bios (CSM on the dark hero), allowed DP boots to see bios and windows at startup, vs blank screen.


Interesting that you got it working at boot by changing the CSM legacy boot vs UEFI option. I did mess with these settings for Windows 11 upgrade and I didn’t notice it affecting the blank screen issue with the monitor. Funny thing is that even when it boots into Windows the handshake still doesn’t occur. You would think when Windows loads , the graphics card drivers would also prompt a handshake (HDCP?). After I power cycle the monitor then restart the PC, I can see the bios POST screen, so it doesn’t seem to be something related to the CSM setting, but appreciate the tip nonetheless.

1 Like

That is … probably the oddest combination I’ve seen yet. Did you by chance perform a ‘load factory defaults’ at any time during that?

Yes, very interesting - as I’ve never had a black screen and I got this Spectrum shortly after I had Windows 11 on my rig, since I was a near day 1 tester from back in May. But since I built the rig I’ve always used UEFI + Secure boot to load the OS, regardless of whether it was 10 to now 11. So, there may be more to this than meets the eye.

1 Like

BIOS update (agesa most likely the result but there had been indications on ASUS’s forums about the CSM issue as well. I haven’t yet been able to use HDMI. DP only at this point for both Model3s. Latest drivers for the 3080TI.

And lately with Win11 seeing better dual monitor support but waking from sleep or deep sleep has still been an issue with these monitors time wise. Sometimes the split screen is blank.

1 Like

Yeah, I’ve been installing the Betas from MSI for my MEG X570 Godlike since Win11 came out - going through a variety of Agesa builds too. The latest 1F0 build finally has support for Win11 native, but all the previous beta builds were Beta builds almost exclusively because of new Agesa builds. Still had 0 issues. However, I’m also not using an HDMI 2.1 enabled GPU, so that could be a factor for me as well.

As for the wakeup issue - yeah, it’s a bit of a pain, for sure, but we haven’t gotten a resolution for the slow wake times.

To answer this a bit better:

According to another post I made, basically when the monitor goes into standby, one of the controller chips puts some parts of the boards to sleep - not all - but upon waking back up it sends what amounts to a blanket "reboot’ call to everything, causing everything to ‘reset’ - most notably the USB hub.

I suspect that this reboot call is what causes the Spectrum to take so much time to restore itself from sleep mode.

Incidentally, I just upgraded over the past weekend to an eVGA RTX 3080 Ti also. I’m on driver 511.79, and I have had a couple of small issues with using the Spectrum on HDMI 1. One was if I enabled G-Sync for both full screen and windowed applications, a few games refused to load. Once I changed it back to full screen only, though, the games launched. Another was when I tried the testufo site from blurbusters, and the monitor was inexplicably at 120 Hz, not 144 Hz, refresh. Changing it caused my screen to tear - but reverting to 120 fixed the tear, and trying 144 again did not cause it to tear.

But at least I now have live test data to show that it is 1) an issue, and 2) random. Which only means we need to focus on this issue, and all issues, as much as we can to find the root cause.

1 Like

2 days ago I had problems getting my Spectrum to see the PS5 after having my PC on. Had to power off completely to get any response including removing USB devices.
Today it will not see it again and I have a yellow OSD all the first column is illegible, a few moves in the OSD then the screen locked completely. Full power off (plug at wall) only seemed to work when USB DAC was removed from spectrum USB as well.
Is there a full power off of the spectrum by holding either button for a set time as I tried and failed!
I will see how things go and if a problem occurs try to make clear notes of what happens.
My monitor came on Firmware 105

1 Like

If you have the yellow OSD issue, please contact Support. We really need to get as many of these in to repair to determine what is causing the issue.


Thanks @nkyadav ,
The yellow OSD rectified itself after the full power off and disconnection of the USB DAC.


Interesting. Without the DAC, does the yellow OSD occur at all??

This is the first time that we’ve had a report that it is (at least partially) caused by a device connected to the USB hub.

It would be interesting to see if repeated testing definitely points to that DAC in your particular case.

I have tried to recreate the fault without success, turned USB power to on and had all devices connected as before. Good that it is not faulting now, but I thought I could have at least locked the monitor up like it did before. Sorry no help.


Had the Yellow OSD and monitor locked until full power off (plug removal) again.
I had put the PS5 into restmode last night (usually power off fully, but not the first time I have left it in restmode)
Powered on screen and PS5 and the screen was black, pressed the Menu button and the yellow OSD displayed.
I ran for my camera to take photo, came back to black screen and monitor unresponsive.
Can’t see any link to USB or USB hub this time, USB DAC wasn’t connected.
Monitor back working again now.


To your recollection, has this ever happened when you’ve not put the PS into restmode?

Sorry I can’t be sure.
I have only had the Yellow OSD twice now.
The first was when I was messing around getting my setup sorted.
I will update and take note each time it occurs.


That is going far above and beyond what a lot of people would consider reasonable, so I personally thank you for any data you manage to get to us.

Just updated to trial PS5 Firmware and it’s brought back the yellow OSD.
Got the OSD back normal but cannot get any input to display
PC - Displayport
Done several power off cycles.
Now powered off and try leaving for 15 mins or so

1 Like