Any guide for factory reset?

I think that could work, assuming the recovery partition is working. but I think something is going wrong on that step.
@iKirin, could you check if the recovery partition image is working? I think this is the third case of the windows reset causing more issues…

1 Like

I second this - the only thing worse than refreshing your V to find out the recovery was messed up is doing the same thing but three years later.

Hey @Patrick_Hermawan, I assume there’s a copy of this recovery image on my V? Any chance you know the magic shell words to help me power-poop this one out so we can check?

1 Like

Not all Windows 10 installs have a dedicated partition. You can go to Disk Management (diskmgmt.msc) and see if there is a hidden partition with the size of around 4-8 GB, then its most likely to be the recovery partition. I have fully wiped my V, so I couldn’t check that. Anyway, if you found it, you can go to “diskpart” utility to mount the recovery drive, then you can access it from the explorer. The recovery image is usually called install.wim. If you see a big .wim file, it must be that.

However, most computers that come with Windows 10 no longer have a dedicated recovery partition, especially on SSD where space is a premium. Instead, when you perform a recovery, it will simply re-create a new install from your existing install (minus your personal data/apps). Thats also why some problem stay persist after numerous recovery attempts.

(unless you are Acer, then it is cool to deliver the recovery of your tablet in CDs that you cant access on your tablet without 3 separate accessories)

1 Like

I suppose the recovery partition being 1000MB might also indicate a problem?


ok well i guessbeing empty could be a problem.

So I made a recovery image on my USB from Windows app, and tried to reset the machine by
Power button + volume down button
and reset from USB, now I got a bigger problem.
reset error
After this, nothing happened so I had to turn off the laptop by the power button. Later, as I turn on the laptop, I have a black screen with "Shell> " message.

Now I can’t even turn on the laptop, and just get stuck with "Shell> " message. I am waiting for the eve customer service :sob:

Have you tried turning it off and on again (while mashing esc/del to get into bios so you can turn off boot into efi shell)?

Try booting from the USB, but instead of reset or refresh, click the “repair” option

Thanks for the help. However, I think I have more serious problems here. I can go and change the BIOS setting, and whether I set the USB(I got the image from eve V support team) the priority booting option by UEFI mode or Legacy mode, I get the same weird screen.

boot1boot 2shell error
And after all, I don’t know what to do on that screen.

If you set Boot Option #4 to “Disabled” instead of “UEFI AP: UEFI: Builtin EFI Shell”, what happen?

Also how did you flash the USB? With Rufus?
If its Rufus, I got the best chance with “MBR for UEFI computer” (and the BIOS also set to UEFI). Make sure it also boots on other computers.

And still IMG_20171220_120834

Same if I choose Legacy booting option. Eve customer service gave me the image file itself in a zip, and told to unzip it on the USB. So I didn’t need to flash the USB but only had to unzip the file.

Found a link that had same problem. However in this case, it’s Ubuntu.

I think the problem can be fixed with right EFI commands. I found the EFI commands from here. However I am worried that I am further messing up with my laptop…

Since you got a bunch of files and folders, Can you give this a try? I used this for my Windows 8.1 custom ROM, and it did boot

Then use Rufus to flash the ISO to the USB

1 Like

Alternatively - Just heard back from EVE, If you can boot from USBs, download the factory image file here:
Please do not share the factory image link. kthx.
Edited by @iKirin

Directions from Eve support:
We’ve uploaded the image we’re using for installing on every Eve V that leaves the factory & made it available to you.

As for the installation, please follow the following quick steps (they’re basically the same Konstantinos sent you)

  • Clear a USB-Drive with at least 16GB, format it to NTFS and call it ‘WINPE’
  • Unpack the .zip on the USB-Drive
  • Restart the V & press Delete to get into the BIOS.
  • In the Boot Options set the USB-Drive as the first option, Hard Disk as second Option.
  • Save & Exit, now plug in the USB-Drive
  • The USB-Drive will now Install Windows in Audit Mode
  • After the Installation is Finished, unplug the USB-Drive and start the V without the USB plugged in.
  • This first Boot is now in Audit-Mode which we use at the factory to QC every single V before it leaves the factory
  • A Popup should appear right at the start with an Option to set Windows to the OOBE - please use that.
  • The V should now restart, with the Windows Experience that every Customer gets from this point on.

If you have means to do this, this should reset your V as well as possible. It should’ve been possible for you to do this with the Windows reset, but there might have been a bug with the original image in your V.

But if you don’t want to do this, we will also have the drivers available soon.

@Jason_Yang, @Patrick_Hermawan, Thanks for the info. I created the bootable USB and followed Jason’s steps as I got the same instruction from the Eve customer service. However, as soon as I turnon my laptop, I end up in the shell screen.

First, the BIOS setup always goes back to the default value(time in 2009, and UEFI booting with quiet and fast booting enabled) every time I turn off and turn on the laptop.

Next, I tried Windows 10 factory image(from eve) and Manjaro KDE, and both ended up in EFI shell screen. However, I managed to install Manjaro XFCE which was under 2gb. I guess the size of the installing OS is related to the UEFI setup?

Even if I can boot up in Manjaro XFCE, the kernel and the login screen resolution does not match. I guess it has something to do with the graphic driver.

Currently what I want to do is fix the UEFI shell screen error and install WIndows 10 factory image. To do so, I need to fix the UEFI shell screen error. I am still getting help from the eve customer service.

@iKirin Is there a UEFI image that can be flashed? This could be symptoms of something wrong with the motherboard, but flashing it may help.

There is none publicly available.

@Jason_Yang I’ve also removed the link as our support has asked to not have the image be shared publically :wink:

@superorca What does it say after installing the image? An error or success? :smiley:
Also, you can try to set the boot mode to legacy - that has been known to fix that issue for some people (I know it’s very weird but our engineers are already on it)
As for the BIOS settings not sticking, I’m unsure why that is to be honest :confused:

Hi @iKirin,

Whichever boot mode(UEFI, Legacy) I set, as I turn on the laptop I end up in the EFI shell screen look like this.
So I can not start installing the image.

I got a reply from @reappear that maybe the error is related to GRUB.

I guess the error(shell error screen, BIOS reset, etc) comes from he UEFI shell, but no idea how to fix it. Any ideas?

Did you rename the Flashdrive to WINPE? that did it for me.

Yes I did exactly follow the instruction.

This is exactly what I did: