60Hz refresh rate, and no higher

Running firmware 104, tried new cables, yadda yadda. Can’t go over 60Hz at any resolution. My GPU is a Radeon VII, so I don’t expect 144Hz over Displayport. Tried HDMI as well, all the way down to 1080p. Did I just replace my 4k60 LG monitor with another one, only more expensive? The colors are nice and all, but not worth the price of admission alone.


rtx3000 works fine 144 both displayport and hdmi
have you set hdmi to 2.0 compatibility mode?

also i googled VII wont work 4k144, it can do only 1440 in 144

I’ve looked up the Radeon VII specs and this is correct.

In order to get 4K @ 144Hz your video card needs to support DSC. This isn’t available with Vega-based cards, only with RDNA. (Same goes on the Nvidia side, where the GTX10x0 range don’t support DSC either.)

With HDR enabled, the highest refresh rate you can get at 4K is about 95Hz. However, the Spectrum doesn’t advertise this as a possible refresh rate and the next lowest is 60Hz. If the Radeon driver software allows it, you may be able to create your own custom resolution / refresh rate combo here.

With HDR disabled (i.e. everything is running at 8-bit, including the signal from the GPU to the monitor) then you should be able to get 4k @ 120Hz. However it looks like there’s a bug somewhere that doesn’t make this available, at least with Radeon cards.

1 Like

As I said, I don’t expect 4k 144hz. That isn’t the problem. The problem is the best I have been able to manage is 1080p @ 120hz. 1440p allows for 59.940 and 60Hz. I’ve got another cable on order, but this doesn’t quite feel like a cable thing anymore. How often is 23.976 or 29.970 an option for monitor refresh rates? It seems like my Spectrum thinks it’s a tv.



Thinking about it a bit more, I’m starting to wonder if it’s the scaler + displayport. Turning on GPU scaling in Radeon software blanks the display. Turning it off, the display comes back. But this only happens when plugged in via displayport. On HDMI, GPU scaling works just fine. As it is, I don’t have anything that outputs HDMI 2.1, so I can’t really test refresh rates that way.

1 Like

Looks like it is not an isolated issue. Maybe we can get someone from the Firmware Team to take a look at this issue?
With custom resolutions utility I managed to set up 4k at up to 73hz, 1440p at 120hz and 144hz (the scaling was AWFUL but at least it worked).
I’d love to use another display on my system or another system on this monitor, but I have nothing better than my RX570 or my laptop with 960M and a single HDMI port.

1 Like

Hi @automaticjerk,

Our team is looking into this and will get back to you as soon as we find a solution.

Apologies to hear you are experiencing issues with your Spectrum.


Oh oh, i also have a radeon vii in my pc and my spectrum should arrive tomorrow… and now i am reading this :face_with_spiral_eyes:

Hopefully there will be a solution :crossed_fingers:t2:

1 Like

Trying turning signal processing in Radeon drivers from 10bit to 8bit if you haven’t already.

1 Like

That’s been tried, duder. No change. :frowning_face:

1 Like

Same problem here with a Radeon RX570. I would also expect at least 4k@120Hz or 90Hz.

Joining the club with my vega 56.
However, I was fiddling around today on linux and managed to create a custom mode/resolution via xrandr that allows to run the display with 4k120.

So the problem seems not to be hardware, but some interaction in windows or the radeon driver.
From what could I see when creating a custom resolution on Windows, I’d say the radeon driver locks the so called “pixel clock” on a level way too low.
From what I noted down, it’s limited to about 655Mhz, while to achieve the 120Hz on Linux it clocked up to almost 1097MHz.

And when i tried to set a custom resolution via the 3rd party tool CRU, it says
Range limits: 48-144 Hz, 324--324kHz, 1300 MHz
Name: ES07D03
regarding the monitor. Since I’m merely tinkering around, I can only guess that the 1300Mhz refer to the maximum pixel clock that the monitor supports. Funnily enough, even the tool does not allow a value higher ~655 Mhz, translating to about 66Hz refresh rate.

So with all that in mind, it could be a driver issue but I’m not sure how to contact AMD on this.
I hope however this info helps to bring the solution forward.

for now I posted a report on the tech support megathread on reddit


That’s pretty interesting, actually. Though I’m still leaning on hardware. I haven’t heard anything about this sort of issue with Navi chipsets. Every other person I’ve seen with this so far has had a GCN based card.

Is there any chance you can share the ModeLine that works?
Also, do you know if KMS and Wayland can be persuaded to use it?

So I am going to add a way for enabling at least 100Hz on Windows:

  1. run the pixelpatcher tool, to unlock pixel clock limits in the radeon driver
  2. open Radeon Software → Settings → Custom Resolutions
  3. create a custom resolution:
    • click “Create New”
    • enter 100 in refresh rate field
    • select CVT reduced scan
    • see how all the timing fields are calculated automatically
    • press on Create on bottom of the dialog
  4. go to windows display settings
    • select 100Hz refresh rate

I think what we need is the Spectrum to support and advertise CVT-rb2 modelines in EDID - which will allow staying within the bandwidth limits of DisplayPort 1.4, but still achieve 120Hz. At least 100 is better than 60 for now imo :slight_smile:


Is 100 as high as it can go? I will try this out when I get back home later

EDIT: What GPU and what Driver Version are you running? I tried the tool on my system but after reboot it corrupts my driver. RX570 on 21.12.1

While this works great in 4k, doing the same thing in 1440p is a bit blurry. It’s certainly better than what we had before, though.

I have never really tinkered with KMS, so I dont know about that, and currently I can’t start a wayland session (I just get thrown back to my login shell, sddm).

The ModeLine I noted down :

# 3840x2160 119.94 Hz (CVT) hsync: 274.31 kHz; pclk: 1097.25 MHz`
Modeline "3840x2160R"  1097.25  3840 3888 3920 4000  2160 2163 2168 2287 +hsync -vsync
1 Like

Thank you, that one works for me, too!

As to KMS … well.
It seems to me that the wayland compositors do not have a place for putting Modelines like X does.
So the only modes usable are those declared in EDID. Therefore I do not believe we can easily trick wayland into 120Hz.

I think so. At least I couldn’t come up with settings that radeon software would accept.

MSI Vega56, Radeon Software 21.12.1