4K Eve Spectrum dead?

Hello all, I have firmware 1.04 and the monitor has been somewhat functional. While playing PS5. My monitor would go black and wouldn’t show anything until I press the PS button on the controller. The image comes back for a bit but if I access the in game menu it would go black again.

Today, I was using it with my PC and turned it off. An hour later I wanted to power it on to game but the monitor is completely dead. I have unplugged the connections and waited, plugged it back in right away and nothing.

Any idea what happened? Its on a surge protector and nothing has happened to the electricity.

Thank you.

The Spectrum needs a firmware update to support PS5 VRR.

2 Likes

Gotcha well hopefully that can help others. My whole issue now is that my monitor won’t even power on… this happened out of nowhere.

I’ve tried that a couple of times. Make sure to turn off VRR in PS5 settings. Unplug the power supply and try again.

1 Like

Hi @J_Hdz & @8BiTw0LF,

Please check out the below. I’ve tested the beta firmware for the VRR PS5 and works perfectly well.

2 Likes

Hello, I tried to upgrade to 107 and windows upgrade tool showed that I have to unplug power, etc… I did it, wait 10seconds and plug in back. Monitor started but no info about upgrading. When I put usb-c cable with my mac, it starts doing something but after a few seconds macbook is restarted, crashed. I connected windows again and try to downgrade or same upgrade version but it shows Device Updating Fail. Not sure what I can do. I think I need some reset or something to load factory firmware or something. I can not find how to do it.
Thanks

Hi there,

I suggest performing more power cycles, with unplug more than 15 seconds each. What is the colour of the LED light?

Also keep the connection with your windows device throughout the entire process. Switch only when the device clearly shows that the process is finished.

I tried it at least 20 times. LED light is white/blue, see photo.
CleanShot 2022-10-14 at 07.59.40@2x

I’ve been keeping an archive of scaler firmware versions so I might have something that’ll help. I’ll DM you the link.

One of the versions is a “v104 rollback” that was released around the time that v105 came back. When I recently had issues upgrading to the v107-T1117 test build, I used that v104 firmware to get back to a stable state. I was able to upgrade from there.

Here are my tips for making the firmware flashing process easier:

  • Always ensure you’ve got a second screen available. Running the firmware flash tool from a laptop is a good idea.
  • Unplug all USB devices from the Spectrum. You want the only USB cable to be the one between the Spectrum and your computer.
  • You will need to remove power twice during the update process: once when the firmware program says it’s done, and again when the Spectrum has finished its update.
  • The easiest way to remove power is to reach under the front of the Spectrum and locate where the power cord plugs in. It only needs to be pulled out by about 6mm / 0.25in to kill power, and then it’s easy to put back in.
  • Always count to 10 before plugging power back in. This gives enough time for the circuits in the Spectrum to loose any charge they hold.
  • Watch the power LED on the Spectrum when it’s going through the “Processing Update” phase after the first power removal. It should go through 4 colour changes, ending on magenta (pink-purple). If it doesn’t end on magenta then it didn’t work properly.
  • If a flash doesn’t work properly, you need to flash a different version. Re-flashing the same version won’t trigger the “Processing Update” phase of the process.
4 Likes

Thank you, it helped. I use now old 104 and when I will time I will try to upgrade it again. Because I can use more hz with this older firmware with macbook pro m1 and usb-c. Really thank you, you saved me

2 Likes