10 series with Eve Spectrum & Display Port 1.4 capabilities

Hi, I have recently got the 4k 144Hz monitor & I have a 1070 ti with Display Port 1.4 (however, without DSC).
It looks like the maximum capabilities should be 4k 98Hz without chroma subsampling, however, the only options for refresh rate are 60Hz or 100Hz+ (which exceeds the limit).
I have tried creating a custom refresh rate of either 75Hz or 98Hz & neither works without enabling chroma subsampling.
I was wondering is there a fix on my end that I can do to enable higher refresh rates without enabling chroma subsampling or would Eve need to apply a firmware update to enable some refresh rates between 60Hz & 100Hz?

2 Likes

I might also want the option to set an intermediate refresh rate, e.g. 90Hz. I’m still stuck at 60Hz because at 100Hz the system will drop to 6 bit color. How does Windows determine which video modes and refresh rates are available to pick from? Is it through EDID negotiations with the display? So in order to get a 90Hz option do we need a support for it added in the monitor’s firmware?

2 Likes

Use CRU to create a custom resolution with reduced timings. 4k98/RGB/10b and 4k120/RGB/8b are both possible when you use tight values to stay within the DP1.4 bandwith limits.

These are the timings I use for both, with my 1080Ti: Spectrum timings - Album on Imgur

Add these to the DisplayID 1.3 extension data block as a new resolution. I believe there’s already a DID1.3 block with a 4k144 resolution in the original EDID, but I can’t remember for sure. If there isn’t, you can create one under Extension blocks (Add > Type: DisplayID 1.3 > Add > Detailed resolutions).
If they don’t work properly, modify the TV resolutions data block under the CTA-861 block and remove the 3840x2160 resolutions with refresh rates above 60.

5 Likes

Thanks for the reply.
I have tried messing with CRU yesterday, but I couldn’t get any custom resolutions showing in the display adapter list (or Nvidia control panel).
I just tried going through your steps (DisplayID 1.3 didn’t previously exist so I had to add it), however, I still can’t get it to show up. This is what I have:
image
With this under DisplayID 1.3:
image
I have tried editing both the active & the non-active profiles but nothing I do in CRU seems to be changing anything. I have used both the restart64.exe & restarted my computer.

Is there anything I need to install/update to allow the settings to be changed? It looks like there is mention of Nvidia pixel clock patcher, but it sounds like that is only for HDMI & DVI?

Thanks again for any help.

1 Like

I also did not get anything new to show up with CRU, but I’m probably doing something wrong. I have no idea what the CTA-861 extension block is so maybe I shouldn’t even be messing around with these settings.

E: I was actually able to add a 90Hz refresh rate in the “DisplayID 1.3” extension block category. Choosing this resolution in Windows retained the full 8 bit color resolution, but turns out motion is less smooth than at 60 Hz so very likely its not actually 90 Hz, but perhaps half of that or something.

2 Likes

Thanks, @Toesoe I have got both mods working now (98 Hz 10 bit & 120 Hz 8 bit).
Essentially I reset all changes I made with CRU using reset-all.exe (I have also recently done a fresh install of a graphics driver), then I restarted my computer, created the DisplayID 1.3 extension block:
image

Created the two resolutions as under the same slot:
image

Where each has timings that @Toesoe gave:
image
image
Then I restarted my computer, 98 Hz should now be working, but 120 Hz won’t as there is already a 120 Hz profile that needs to be deleted, so go into CTA-861 & edit TV resolutions & delete the 3840x2160 120 Hz profile (I think it was at the top of the list):
image
Then do a final restart & both refresh rates should now be working without 4:2:2 chroma subsampling.
I selected the refresh rates by going into settings->Display->Advanced Display->Display adapter properties->Monitor then screen refresh rate (I’m using Windows 11).
You can open the Nvidia control panel & change the settings such as 10 bit if it isn’t already for 98 Hz & using the full-colour space.

Thanks again @Toesoe for the help.

4 Likes

Hold on… @InfraredWolf’s post inspired me to try once more, and I think I made a breakthrough? I tried adding a few different custom refresh rates, 98Hz, 90Hz and 75Hz. All of them ostensibly worked, but the motion in Windows was still more jittery than at 60Hz. However, after inspecting further I think this might be a Windows problem and not a display problem. Maybe animation in Windows is 60Hz based or something? UFO test looked alright and thus I ended up adding one more refresh rate, 119Hz (not to be confused with the stock 120Hz which drops to 6 bit color) and what do you know, now everything looks smooth.

I still wish someone could explain to me why this custom resolution works when the default 120Hz does not, but I suppose one shouldn’t question a good thing? Thanks to both of you for your help!

1 Like

That’s strange. I’ve not experienced anything like that (and I’m fairly new to all this) so I probably don’t know how to fix it, but if you change to the stock 144 Hz setting, does it feel smooth or is it also jittery?
If it is maybe it’s a cable or driver problem?
If it’s only the custom settings that are jittery (except it sounds like 119 Hz works well) then maybe there are some conflicts with already created profiles? Have you created any custom resolutions in the Nvidia control panel? Have you reset Custom Resolution Utility to default & then made the custom ones afterwards?

1 Like

Yes it turns out even on my other machine which has worked from the get go, 100Hz is looking pretty stuttery on Windows. I mean stuff like dragging windows around etc. 144Hz looks fine, 120Hz also, 60 is what it is, but anything else not so much. I think I already succeeded in setting the 90Hz rate earlier, but since it doesn’t look too good I assumed something was still broken when it was probably actually working.

Thanks to the custom resolution shenanigans I can now get a smooth experience from this laptop too, which is nice.

1 Like

Oh, you guys have opened a new can of worms for me to play with lol - and I am already booked with firmware testing!

I wonder what (if anything) this can do for my 970? Seems like I have some reading to do tonight. or this weekend. Yeah, this weekend - firmware comes first!

Seriously, though, very nice finds all around. Kudos to @Toesoe for suggesting CRU and for posting the timings on imgur, to boot.

3 Likes